Horizontal line bug in WBS styling

0 votes
asked Feb 14 in Bug by anonymous
Hello.

The creole syntax for horizontal lines doesn't work correctly when used with the new beta styles for WBS diagrams: the lines are indented to the right and extend beyond the node boundaries. That's true for all types of horizontal line.

For an example see:

https://www.plantuml.com/plantuml/png/JP2nJiCm48PtFyLLOW15BQGIMujAO6082qkNBYO-qXFE7JexGe3wxbmSXBhybh_xRFswNSfUy-ThSeiFbGx3g0WNwVBARLB-YdZdRFP8lbS_m8y3Q8dnGQ8eDD5txqOQEtgLaSFCzqVAQ9mbO7a2y2HAtyBPn_j8FG_86JeBr39-zjeJGtqptuXf68SzXNo4-dQ29tToc-k_GWlayD_LbQuLl8XaLrMmtK9JMnwuKS-TVM2qWkKIsjhom2twjmABkZvNrqLThKord5M3E-GmBUWN

If you comment out the procedure call, you'll see the horizontal lines display okay.

If it's not possible to combine creole + beta style, is there a way to achieve a similar result with just the beta styles?

Many thanks!
commented Feb 14 by The-Lu (49,760 points)

Hello all,

It seems to be due to:

HorizontalAlignment center

Compare, with:

or without:

If that can help for debugging...
Regards,
Th.

commented Feb 14 by anonymous

I think it's related to MinimumWidth as if that's commented-out, the horizontal lines render okay – even if centred.

1 Answer

+1 vote
answered Feb 14 by plantuml (279,680 points)

Thanks for the report.

This is indeed a bug, which has just been fixed on the online server.

commented Feb 15 by anonymous
Many thanks for picking this up. Is the horizontal alignment working okay? It looks like the text below the lines is left-aligned, rather than centred?
...