Issue in generating state diagrams with Doxygen

0 votes
asked Feb 17, 2018 in Closed question / help by Laurent

I try to generate activity diagram with PlantUML thorugh Doxygen. I succeeded for sequence diagrams, timing diagrams, activity beta diagrams, but failed for state diagrams with the following error:

Dot executable: C:\ProgramFiles\Graphviz2.38\bin\dot 

File does not exist Cannot find Graphviz. You should try 

@startuml 

testdot 

@enduml 

or 

java -jar plantuml.jar -testdot

The code I am using is the following: 

* @startuml 

* [*] --> State1 

* State1 --> [*] 

* State1 : this is a string 

* State1 : this is another string * 

* State1 -> State2 

* State2 --> [*] 

* @enduml

Do you have any idea to solve this issue ?

Thank you for your support

Best regards

1 Answer

0 votes
answered Feb 17, 2018 by plantuml (200,240 points)
Did you install GraphViz ? (see http://plantuml.com/graphviz-dot )
commented Feb 18, 2018 by Laurent Perron
Yes, and when i try java -jar c:\ProgramFiles\Graphvi2.38\bin\plantuml.jar -testdot
I have the following output

The environment variable GRAPHVIZ_DOT has been set to c:\ProgramFiles\Graphviz2.
38\bin\dot.exe
Dot executable is c:\ProgramFiles\Graphviz2.38\bin\dot.exe
Dot version: dot - graphviz version 2.38.0 (20140413.2041)
Installation seems OK. File generation OK
commented Feb 18, 2018 by plantuml (200,240 points)
Very strange...
Could you try:
@startuml
testdot
@enduml
in Doxygen ?
commented Feb 18, 2018 by Laurent Perron
Hello again

It is solved:
The DOT_PATH setting in Doxywizard was set to the appropriate path. I removed the value (so nothing in this setting) and now it works

If anybody understands why, I am interested :-)

Thank you
commented Feb 18, 2018 by plantuml (200,240 points)
Usually, "Program Files" has a space character between Program and FIles.
Are you sure there is no space for you ?
Maybe it's related to your issue ?
commented Oct 11, 2018 by anonymous
Nope; nothing to do with Program Files. This error is only triggered when doxygen/plantuml encounters  [*] --> or -->[*]. In the same source file I am able to generate activity diagrams without any problem.  The problem only comes when the program sees [*]
commented Oct 18, 2018 by anonymous
edited Oct 19, 2018 by
Looks to be a windows filename incompatibility.  When I copy a file called 'dot' (from 'dot.exe') and add this to the directory 'C:\Program Files (x86)\Graphviz2.38\bin', then the path can be included in doxygen and the state diagram does get generated. I guess there's a check for 'dot' in the state machine generation that is different to the sequence chart.
( Refer https://github.com/plantuml/plantuml/issues/9 Dot not found even when in the PATH )
...