PlantUML word template Error 5

0 votes
asked Jul 28, 2023 in Bug by bartexsz (120 points)
Hi, I'm trying to use Plantuml Word template. I've put plantuml.jar binary and template v34 to word startup directory.

When I open Word, PlantUML ribbon is visible. I can hide and show plantuml. However when I try to regenerate image or open preferences I get Run-time error 5:  Invalid procedure call or argument.

I have graphviz installed, tried both plantuml binary with and without graphviz embedded. Binaries itself work, I can open some directory and generate images based on text files, My assumption is that Word macro has some problem opening the plantuml binary.

Any way to fix this problem ?
commented Jul 31, 2023 by bartexsz (120 points)
Ok, nailed down the problem

Looks like a problem with this commit: 7962a3ac9bf6812f5c05df8e462ba312f4d695a2.

Downloaded version one commit earlier 799a9551b0191c540070fce8a71f4ca1715bcf2a and it works now.

1 Answer

0 votes
answered Mar 15 by Laurent

yes, 799a9551b0191c540070fce8a71f4ca1715bcf2a  is to be used with Word 365 and later :/