PlantUML word template Error 5

0 votes
asked Jul 28 in Bug by bartexsz (120 points)
Hi, I'm trying to use Plantuml Word template. I've put plantuml.jar binary and template v34 to word startup directory.

When I open Word, PlantUML ribbon is visible. I can hide and show plantuml. However when I try to regenerate image or open preferences I get Run-time error 5:  Invalid procedure call or argument.

I have graphviz installed, tried both plantuml binary with and without graphviz embedded. Binaries itself work, I can open some directory and generate images based on text files, My assumption is that Word macro has some problem opening the plantuml binary.

Any way to fix this problem ?
commented Jul 31 by bartexsz (120 points)
Ok, nailed down the problem

Looks like a problem with this commit: 7962a3ac9bf6812f5c05df8e462ba312f4d695a2.

Downloaded version one commit earlier 799a9551b0191c540070fce8a71f4ca1715bcf2a and it works now.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

[Antispam2 Feature: please please wait 1 or 2 minutes (this message will disappear) before pressing the button otherwise it will fail](--------)
To avoid this verification in future, please log in or register.